CentOS 6.X安装TensorFlow问题

浏览: 85

在Centos下安装tensorflow,CentOS 7 没什么问题,直接 pip3 install tensorflow 就OK,CentOS 6.X就问题比较多了,在linux下 pip3 install tensorflow 后进入 python3  import tensorflow 报的一些错误在此记录下:

一、

报错:ImportError: /lib64/libc.so.6: version `GLIBC_2.17' not found

这时候需要安装GLIBC 2.17版本,网上介绍的命令没跑通,如

wget https://ftp.gnu.org/gnu/glibc/glibc-2.17.tar.gz
tar -xvf glibc-2.17.tar.gz
cd glibc-2.17
mkdir build
cd build
../configure --prefix=/opt/glibc-2.17
make && make install

报错:Error: `_obstack@GLIBC_2.2.5' can't be versioned to common symbol '_obstack_compat' 或者 opt/glibc-2.17/etc/ld.so.conf: No such file or directory

试了很多次都没成功,考虑升级glibc到2.17,参考博客:https://www.cnblogs.com/dpf-learn/p/8763696.html

wget http://copr-be.cloud.fedoraproject.org/results/mosquito/myrepo-el6/epel-6-x86_64/glibc-2.17-55.fc20/glibc-utils-2.17-55.el6.x86_64.rpm &
wget http://copr-be.cloud.fedoraproject.org/results/mosquito/myrepo-el6/epel-6-x86_64/glibc-2.17-55.fc20/glibc-static-2.17-55.el6.x86_64.rpm &
wget http://copr-be.cloud.fedoraproject.org/results/mosquito/myrepo-el6/epel-6-x86_64/glibc-2.17-55.fc20/glibc-2.17-55.el6.x86_64.rpm
sudo rpm -Uvh *-2.17-55.el6.x86_64.rpm --force --nodeps
strings /lib64/libc.so.6 |grep GLIBC #查看已有glibc版本

二、

报错ImportError: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found

yum install gcc
updatedb #更新索引数据库
locate libstdc++.so.6 #查看libstdc++位置
cp /home/seng/anaconda3/lib/libstdc++.so.6 /usr/lib64/libstdc++.so.6 #复制最新的libstdc++到lib64

三、

如报错:ImportError:/usr/lib64/libstdc++.so.6: version `CXXABI_1.3.7' not found,libstdc++.so.6没有链接到最新的CXXABI,重新安装下gcc,再复制最新的

libstdc++到lib64;或网上下载文件libstdc++.so.6.0.22也可解决

strings /usr/lib64/libstdc++.so.6 | grep 'CXXABI'  查看动态库CXXABI版本
cp libstdc++.so.6.0.22 /usr/lib64/ #下载的libstdc++.so.6.0.22复制下
rm -rf libstdc++.so.6
ln -s libstdc++.so.6.0.22 libstdc++.so.6

参考资料:https://blog.csdn.net/yemazhuxing/article/details/80399595

四、

报错:/lib64/libc.so.6: version `GLIBC_2.18' not found

wget http://ftp.gnu.org/gnu/glibc/glibc-2.18.tar.gz 
tar zxf glibc-2.18.tar.gz cd glibc-2.18/
mkdir build cd build/
../configure --prefix=/usr
make -j2 && make install

五、

报错:FutureWarning: Conversion of the second argument of issubdtype from `float` to `np.floating` is deprecated. In future, it will be treated as `np.float64 == np.dtype(float).type`.

pip3 install -U h5py

六、

报错:RuntimeWarning: compiletime version 3.5 of module 'tensorflow.python.framework.fast_tensor_util' does not match runtime version 3.6

去官网找对应版本:https://pypi.org/project/tensorflow/#files

pip3 uninstall tensorflow
pip3 install tensorflow==1.11.0

目前centos 6.X 使用tensorflow就碰到这些问题,解决后初步使用没什么问题

推荐 1
本文由 走马兰台 创作,采用 知识共享署名-相同方式共享 3.0 中国大陆许可协议 进行许可。
转载、引用前需联系作者,并署名作者且注明文章出处。
本站文章版权归原作者及原出处所有 。内容为作者个人观点, 并不代表本站赞同其观点和对其真实性负责。本站是一个个人学习交流的平台,并不用于任何商业目的,如果有任何问题,请及时联系我们,我们将根据著作权人的要求,立即更正或者删除有关内容。本站拥有对此声明的最终解释权。

1 个评论

那就用centos 7, 简单点^-^

要回复文章请先登录注册