IIS7下配置SSAS通过HTTP远程连接

浏览: 8135
安装环境
操作系统:Windows7、Windows Server2008
IIS版本:7.5

IIS7下配置SSAS通过HTTP远程连接详细的步骤如下
1、首先到分析服务器的SQLServer安装目录中找到如下目录和文件,路径如下:D:\Program Files\Microsoft SQL Server\MSAS10_50.MSSQLSERVER\OLAP\bin\isapi
1.jpg

2、在D盘新建一个olap文件,把上述的isapi内的所有东西全部copy进去。
2.jpg

3、在IIS中新建一个应用程序池,名称为olap,托管模式选择经典,如下设置
3.jpg

4、在IIS默认网站下新建一虚拟目录,名称为olap,物理路径选择第二步新建的d:\olap的文件夹,具体操作如下图
4.jpg

5.jpg

5、在虚拟目录OLAP上点右键,选择"转换为应用程序",然后对应的应用程序池选择第三步创建的olap模式,具体如下图
7.jpg

6.jpg

6、在OLAP的功能视图区,双击"处理程序映射"
9.jpg

7、右键,选择“添加脚本映射”,选中刚所建虚拟目录下的msmdpump.dll文件,确定即可。会出现是否允许ISAP拓展,点击是即可,具体如下图
10.jpg

11.jpg

8、配置IIS身份验证,在功能视图中,双击“身份验证”,出现如下对话框
12.jpg

13.jpg

9、上面是启用匿名身份验证的,其他都是禁用的。右击匿名身份验证,选择编辑,出现如下对话框:
14.jpg

点击设置输入相应的用户名和密码,特别注意:这里的用户名必须是可以访问SQLSERVER的。如果多维数据库带有实例名的话,比如.\sqlserver2008切记要修改msmdpump.ini文件,打开msmdpump.ini文件,修改对应的ServerName为.\sqlserver2008即可。

25.jpg


测试配置是否成功
1、在多维分析引擎里面输入:http://ip地址:端口号/IIS站点名称/msmdpump.dll 即可,例如:本机IP地址:192.168.156.139 端口:80 IIS站点名称:olap
访问如下:http://192.168.156.139/olap/msmdpump.dll
15.jpg

16.jpg


2、在EXCEL里面连接Cube配置如下:打开Excel,点击数据,来自其他分析数据源,输入访问的 http://192.168.156.139/olap/msmdpump.dll 连接即可,具体如下图
18.jpg

20.jpg

选择对应的多维数据库和对应的Cube即可
21.jpg


其他说明:如果在使用EXCE连接的时候报 XML分析在第1行、第9列处失败:禁用DTD这个错误话。 在应用程序池,选择之前创建的OLAP应用程序池,点击高级设置,启用32bit位应用程序:选择true 即可
11.jpg


PS: 分享IIS6、IIS5配置SSAS通过HTTP远程连接详细解决方案,详情参考以下附件 http://www.flybi.net/article/64
推荐 0
本文由 梁勇 创作,采用 知识共享署名-相同方式共享 3.0 中国大陆许可协议 进行许可。
转载、引用前需联系作者,并署名作者且注明文章出处。
本站文章版权归原作者及原出处所有 。内容为作者个人观点, 并不代表本站赞同其观点和对其真实性负责。本站是一个个人学习交流的平台,并不用于任何商业目的,如果有任何问题,请及时联系我们,我们将根据著作权人的要求,立即更正或者删除有关内容。本站拥有对此声明的最终解释权。

9 个评论

不错,支持一下,沙发了!!!
仔细看看,关注一下。
我按照你的方法配置了一下,但是连接的时候出现”连接超时或已失去连接“的问题,是什么原因呢
这样连接怎么控制权限啊?
yingruyin

yingruyin 回复 zww

7、右键,选择“添加脚本映射”,选中刚所建虚拟目录下的msmdpump.dll文件,确定即可。会出现是否允许ISAP拓展,点击是即可,配置错误
今天按照这个步骤在window server 2008上进行部署总是失败(http://localhost/olap/msmdpump.dll就下载)经过多次重新创建依然部署失败;最后发现创建的iis应用程序池olap改成默认的Classic .NET AppPool部署成功了!
在应用程序池,选择之前创建的OLAP应用程序池,点击高级设置,启用32bit位应用程序:选择false 自己创建的olap就可以部署成功了
这个可以理解为,通过外网也可以访问服务器的SSAS?那个网址那里填192.168之类的IP是不是只是内网的?如果外网的IP应该是哪个才对的?好像我们公司里在局域网内的IP都变成是10.41开头的内部IP地址
win7 64位专业版,按照文章中的介绍一直无法成功连接,将32bit位应用程序设置成false后果然成功了!!

要回复文章请先登录注册